Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#14999 closed enhancement (fixed)

qtwebengine: Update to what should be 5.15.4.

Reported by: ken@… Owned by: ken@…
Priority: high Milestone: 10.2
Component: BOOK Version: git
Severity: normal Keywords:
Cc:

Description

In theory paid-for qt-5.15.4 is due out today. The public changes in qtwebengine have fixed a *lot* of CVEs, a couple were rated as critical or had third-party exploits.

Rather than having to store yet another 300MB+ tarball on gimli, I propose to use a 314KB patch.

I have found one annoyance when using falkon with recent git versions: accessing mail.google.com fails the way some sites used to fail in the 5.12 days. In this case, the problem is slightly worse - killing falkon, rebooting to a different system, then later coming back and booting the first system, then restoring falkon sometimes exhibits the same problem.

The easiest fix seems to be to open www.ggogle.com (that seems to always work) and then change that to mail.google.com. That usually works.

Change History (5)

comment:1 by ken@…, 3 months ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:2 by ken@…, 3 months ago

I see that commercial 5.15.4 release has slipped back another week. And today webengine has had 5 more commits, but nothing urgent.

comment:4 by ken@…, 3 months ago

Resolution: fixed
Status: assignedclosed

Security Advisory 10.1-026 created.

comment:5 by pierre, 3 months ago

I wonder whether the version shouldn't be bumped to something like the date of last commit used or so. I do not think 20210401 is still right (although staying at fool's day date might be tempting, I must say).

Note: See TracTickets for help on using tickets.