#15193 closed enhancement (fixed)
bind9-9.16.18
| Reported by: | Bruce Dubbs | Owned by: | Bruce Dubbs |
|---|---|---|---|
| Priority: | normal | Milestone: | 11.0 |
| Component: | BOOK | Version: | git |
| Severity: | medium | Keywords: | |
| Cc: |
Description
New point version.
Change History (7)
comment:1 by , 5 years ago
| Owner: | changed from to |
|---|---|
| Status: | new → assigned |
comment:2 by , 5 years ago
| Milestone: | 10.2 → hold |
|---|---|
| Priority: | normal → lowest |
comment:3 by , 5 years ago
| Milestone: | hold → 10.2 |
|---|---|
| Priority: | lowest → normal |
| Summary: | bind9-9.16.17 → bind9-9.16.18 |
Now 9.17.18
comment:4 by , 5 years ago
| Owner: | changed from to |
|---|---|
| Status: | assigned → new |
comment:5 by , 5 years ago
9.16.18 released
5660. [bug] The configuration-checking code failed to account for
the inheritance rules of the "key-directory" option.
5659. [bug] When preparing DNS responses, named could replace the
letters 'W' (uppercase) and 'w' (lowercase) with '\000'.
This has been fixed.
9.16.17 released
5652. [bug] A copy-and-paste error in change 5584 caused the
IP_DONTFRAG socket option to be enabled instead of
disabled. This has been fixed.
5651. [func] Refactor zone dumping to be processed asynchronously via
the uv_work_t thread pool API.
5650. [bug] Prevent a crash that could occur if serve-stale was
enabled and a prefetch was triggered during a query
restart.
5649. [bug] If a query was answered with stale data on a server with
DNS64 enabled, an assertion could occur if a non-stale
answer arrived afterward.
5648. [bug] The calculation of the estimated IXFR transaction size
in dns_journal_iter_init() was invalid.
5644. [bug] Fix a race condition in reading and writing key files
for zones using KASP and configured in multiple views.
5643. [cleanup] "make install" no longer creates an empty
${localstatedir}/run directory.
5642. [bug] Zones which are configured in multiple views with
different values set for "dnssec-policy" and with
identical values set for "key-directory" are now
detected and treated as a configuration error.
5641. [bug] Address a potential memory leak in
dst_key_fromnamedfile().
5639. [bug] Check that the first and last SOA record of an AXFR are
consistent.
5638. [bug] Improvements related to network manager/task manager
integration:
- isc_managers_create() and isc_managers_destroy()
functions were added to handle setup and teardown of
netmgr, taskmgr, timermgr, and socketmgr, since these
require a precise order of operations now.
- Event queue processing is now quantized to prevent
infinite looping.
- The netmgr can now be paused from within a netmgr
thread.
- Deadlocks due to a conflict between netmgr's
pause/resume and listen/stoplistening operations were
fixed.
5633. [doc] The "inline-signing" option was incorrectly described as
being inherited from the "options"/"view" levels and was
incorrectly accepted at those levels without effect.
This has been fixed.
comment:6 by , 5 years ago
| Resolution: | → fixed |
|---|---|
| Status: | new → closed |
Fixed at commit 0791109ef614fa91c6fcd38e20ec8237e426ddc9
Package updates.
Update to cups-filters-1.28.9.
Update to bind-9.16.18.
Note:
See TracTickets
for help on using tickets.

Upstream has recalled this release due to an error where the letter 'W' was ignored when processing zone names.