Opened 16 years ago

Closed 15 years ago

#1825 closed task (fixed)

zsh-4.3.2 (or 4.2.6 if the dev version doesn't work out)

Reported by: alexander@… Owned by: Randy McMurchy
Priority: normal Milestone: 6.2.0
Component: BOOK Version: SVN
Severity: normal Keywords: utf-8 Zsh
Cc:

Description

Version increment

One of new advertised features is Unicode support (--enable-multibyte is the defaut, no reason to give this explicitly). Not sure if it is complete enough (let me test it tomorrow), since zsh-4.3.0-dev2 in ru_RU.UTF-8 couldn't display non-ASCII characters in the date (%w in $PS1), thought that "файл" matches "????????" instead of "????" (i.e. counted bytes instead of characters), and counted bytes instead of characters in $#VARIABLE construction. See "Multibyte Character Support" in the INSTALL file for more details.

Change History (6)

comment:1 by alexander@…, 16 years ago

The command line editor understands UTF-8 (unlike the previous versions of zsh). The shell itself is not UTF-8 ready. The improvement in the command line editor still counts as such, because in the previous versions of zsh, the user in UTF-8 based locale could not even see some non-ASCII characters he types at the command line.

comment:2 by Randy McMurchy, 16 years ago

Keywords: Zsh added
Summary: zsh-4.3.1zsh-4.3.2 (or 4.2.6 if the dev version doesn't work out)
Type: enhancementtask
Version: a-SVN

Version increment to 4.3.2 (development version)

There was also (I'm going to close it as a duplicate of this one) ticket #1737 which is for updating to the newest production version of Zsh (4.2.6). This ticket will suffice for both and this one can be closed when Zsh is updated to either version.

comment:3 by bdubbs@…, 15 years ago

The current zsh instructions are basically:

./configure --prefix=/usr 
make
make check
make install &&
make install.info

I see a separate zsh-4.3.2-doc.tar.bz2 file too.

Alex, have you finished testing?

comment:4 by alexander@…, 15 years ago

Yes.

Summary: the instructions you cited work. The development version of Zsh is absolutely needed in multibyte locales (e.g., UTF-8, Chinese, Japanese and Korean) for a working line editor (so that one can type "vim Сотрудники.txt" [i.e. edit the list of employees] and see what he types). The shell itself does not work correctly even in the development version, e.g. a question mark is matched by any (one) byte, not by one character. But it is still an improvement.

However, there is already a precedent (Nano) of not allowing a development version of the package into the book solely for UTF-8 related reasons. So, for consistency, please put a <warning> tag and say that the line editor in Zsh and the shell itself are not usable in UTF-8 locales, and close the bug as WONTFIX.

comment:5 by Randy McMurchy, 15 years ago

Owner: changed from blfs-book@… to Randy McMurchy
Status: newassigned

comment:6 by Randy McMurchy, 15 years ago

Resolution: fixed
Status: assignedclosed

Updated BLFS to ZSH-4.6.2.

Also added a warning to the page for users with multibyte locales. Alexander, I'm closing the ticket, but feel free to reword the warning (or add additional information) if you feel it needs it.

Note: See TracTickets for help on using tickets.