Opened 12 months ago

Closed 11 months ago

Last modified 8 months ago

#22283 closed enhancement (fixed)

fetchmail-6.6.0

Reported by: Bruce Dubbs Owned by: Douglas R. Reno
Priority: normal Milestone: 13.0
Component: BOOK Version: git
Severity: medium Keywords:
Cc:

Description

New point version.

Change History (5)

comment:1 by Douglas R. Reno, 11 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: new → assigned

comment:2 by Douglas R. Reno, 11 months ago

Summary: fetchmail-6.5.7 → fetchmail-6.6.0

Now 6.6.0.

comment:3 by Douglas R. Reno, 11 months ago

6.5.7

fetchmail-6.5.7 (released 2025-10-18, 32215 LoC):

## BUGFIXES:
* When authenticating to an SMTP server, the AUTH LOGIN method (which didn't
  become a proposed standard, and is only the third method fetchmail would try,
  if CRAM-MD5 and PLAIN weren't offered) required that the server returned
  a 334 code followed by a blank and by a decodable base64 challenge we ignored
  anyways.  This is in line with RFC 4952.
    However, to improve compatibility, fetchmail now accepts anything that
  starts with "334 " and disregards the remainder of the line.
  At the same time, AUTH LOGIN was deprecated. AUTH PLAIN should be available
  everywhere AUTH LOGIN is, and is specified in IETF RFC 4616.
* When authenticating to an SMTP server, i. e. esmtpname/esmtppassword are
  defined, check for errors, and skip servers that do not understand EHLO,
  because we cannot negotiate supported authentication schemes with them.
  This should avoid attempting to send a lot of messages and see them rejected.
* When authenticating to an SMTP server, do not send client abort "*" when
  we receive any other server reply but 334.
* Extend 6.5.6's RFC-5321 address-literal fix to MAIL FROM. This might
  apply when we only have a server's IP address and need to quality
  addresses without domain. Fixes Debian Bug#1080025.
* SMTP AUTH can now look up passwords from the .netrc file - for that,
  fetchmail's esmtpname setting must match the login for the given host in
  .netrc. Fixes Debian Bug#1056651 by Ticker Berkin.
* Improve the GSSAPI (Kerberos V) build, which was pretty hard to get working.
  This was improved. Recommendation:
  - For autoconf builds (./configure), be sure to have the desired krb5-config
  executable early on $PATH before running ./configure.
  - For meson builds, be sure to list the path to your krb5-gssapi.pc file on
  PKG_CONFIG_PATH.  (meson will fall back to krb5-config, so if that's on PATH,
  that should also work.)

## TRANSLATION UPDATES were contributed by these fine people - thank you!

6.6.0

fetchmail-6.6.0 (released 2025-10-27, 32381 LoC):

## FEATURE:
* SMTP TLS and STARTTLS support. By default, this works opportunistically,
  attempting to set up a TLS connection to the smtphost if it understands EHLO
  and offers STARTTLS, but will not enforce peer certificate validity for
  compatibility, esp. because "localhost" (the default SMTP host) usually
  isn't listed in the X.509 certificates.
    Behavior can be tweaked by adding /notls (cleartext connection), /tls
  (TLS-wrapped connection, negotiating TLS before conversing otherwise),
  or /starttls (requiring EHLO to offer STARTTLS, requesting the latter and
  requiring the server certificate to validate) to the SMTP host's name.
    Also, you can add /tlsproto=... where ... accepts the same parameters
  as the --sslproto option, which see.
  Ports, if not specified, default to 25 for opportunistic and /notls modes,
  465 for /tls and 587 for /starttls, but can be overridden either by giving,
  say /25 or /smtp for /starttls.

comment:4 by Douglas R. Reno, 11 months ago

Resolution: → fixed
Status: assigned → closed

comment:5 by Bruce Dubbs, 8 months ago

Milestone: 12.5 → 13.0

Milestone renamed

Note: See TracTickets for help on using tickets.