Opened 20 years ago

Closed 19 years ago

Last modified 8 years ago

#287 closed defect (fixed)

Ghostscript 8.00 does not create CUPS pstoraster subsystem

Reported by: richard.downing@… Owned by: blfs-book@…
Priority: high Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc:

Description

CUPS requires a pstoraster subsystem consisting of scripts to drive Ghostscript to create CUPS format raster files. The configuration script pstoraster.convs needs to be placed in /etc/cups. None of these are installed by the current BLFS Ghostscript 8.00 installation. The ESP Ghostscript 7.05 patches do not work with Ghostscript 8.00. Hence the BLFS Printing system is broken. The solution is to change to ESP Ghostscript 7.05-5.

Change History (4)

comment:1 by martin_nowack@…, 20 years ago

Resolution: remind
Status: newclosed

The problem of CUPS ist, that ghostscript 8.0 has a non-GPL lisence. And therefor the CUPS-programmers can't make a patch for ghostscript.

Richard A Downing wrote:

As this has been out for some time now,are there any plans to release a pstoraster patch for cups for it? Richard.

No, the AFPL version of Ghostscript does not have a compatible license.

-- Michael Sweet, Easy Software Products mike@… Printing Software for UNIX http://www.easysw.com

comment:2 by igor@…, 19 years ago

Resolution: remind
Status: closedreopened

comment:3 by igor@…, 19 years ago

Resolution: fixed
Status: reopenedclosed

We have two Ghostscript variants in the book now.

comment:4 by bdubbs@…, 8 years ago

Milestone: old

Milestone old deleted

Note: See TracTickets for help on using tickets.