Opened 19 years ago

Closed 19 years ago

Last modified 8 years ago

#330 closed defect (fixed)

cdrdao-1.1.7 installation instructions are incomplete

Reported by: lucius1@… Owned by: blfs-book@…
Priority: normal Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc:

Description

If you try to build the GUI interface according to the existing instructions, ./configure complains that gtkmm and gnomemm are missing. Inspection of the INSTALL file provided with cdrdao-1.1.7 reveals that building the GUI interface (not the base install) requires not only GTK+ (version 1.2.8 recommended) and gnome-libs (version 1.4.2 recommended) as indicated in the BLFS web page for cdrdao-1.1.7 (except that the BLFS web page recommends GTK+ version 1.2.10), but it also requires gtkmm (version 1.2.9 recommended) and gnomemm (version 1.2.2 recommended). It warns that using earlier or later versions may cause compilation failure, but I got it to compile its GUI interface (WARNING: haven't had a chance to test yet) using GTK+ version 1.2.10 (as indicated on the BLFS web page), gnome-libs version 1.4.2 (as indicated on the BLFS web page), gtkmm version 1.2.10 (has bug fix to let it compile under gcc 3.x), and gnomemm version 1.2.4 (has bug fix to let it compile under gcc 3.x). Furthermore, gnomemm requires gtkmm, and both of these require libsigc++ (version 1.0.4 EXACTLY -- no earlier or later). Also, to get gnomemm to compile, you have to set an environment before running ./configure: GTKMM_CONFIG=/usr/local/bin/gtkmm-config (otherwise, it fails to find the required script gtkmm-config even if it is in your path and even with gtkmm in a place registered in /etc/ld.so.conf). Finally, at least in the case of gnomemm, if you run ./configure with the wrong environment, the build configuration is permanently set wrong (running ./configure again will not fix it -- you have to delete the gnomemm source directory and re-extract it from the tarball).

Note: If you need a later version of libsigc++ for some other purpose, libsigc++ version 1.04 (not earlier versions) can co-exist with later versions.

Files not linked from the BLFS page on cdrdao (perhaps these should get their own BLFS installation pages):

http://umn.dl.sourceforge.net/sourceforge/libsigc/libsigc++-1.0.4.tar.gz http://umn.dl.sourceforge.net/sourceforge/gtkmm/gtkmm-1.2.10.tar.gz http://umn.dl.sourceforge.net/sourceforge/gtkmm/gnomemm-1.2.4.tar.gz

Change History (3)

comment:1 by larry@…, 19 years ago

Status: newassigned

I don't know what I'll do about it, but I have fought all the problems listed below and I need to look at it again.

comment:2 by larry@…, 19 years ago

Resolution: fixed
Status: assignedclosed

Not going to add all those pages for this package's GUI which needs to be updated to GTK2 and GNOME-2.2. Removed all mention of the GUI option.

comment:3 by bdubbs@…, 8 years ago

Milestone: old

Milestone old deleted

Note: See TracTickets for help on using tickets.