Opened 18 years ago

Closed 18 years ago

Last modified 8 years ago

#375 closed defect (wontfix)

Mozilla 1.5 missing dependencies

Reported by: ariszlo@… Owned by: blfs-book@…
Priority: high Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc:

Description

In addition to the libraries listed at http://www.linuxfromscratch.org/blfs/view/cvs/xsoft/mozilla.html#AEN22868 Mozilla 1.5 also requires recent versions of libxml2 and libxslt. I tried to compile Mozilla for a distribution that satisfied all the dependencies listed at your page but Mozilla did not compile with libxml2-2.5.2 and libxslt-1.0.25.

Change History (10)

comment:1 by tushar@…, 18 years ago

Status: newassigned

What was the error you got?

comment:2 by tushar@…, 18 years ago

Resolution: invalid
Status: assignedclosed

I ran a strace during mozilla compilation and did not get any references to libxml or libxslt nor were any installed files linked to libxml or libxslt.

comment:3 by ariszlo@…, 18 years ago

Resolution: invalid
Status: closedreopened

The error occurred somewhere around xpfe and I got a "no rule to make target" message. OK, next time disabled the xpfe components but failed with the same error message again. Then I gave up and installed a binary package of Mozilla so that I can compile Epiphany. That was a lucky move. Epiphany complained that my libxml2 was outdated so I removed Mozilla, updated libxml2 and libxslt, and then I could compile Mozilla! So it seems that Mozilla 1.5 requires libxml2 later than 2.5.2 and perhaps also libxslt later than 1.0.25.

comment:4 by tushar@…, 18 years ago

Please provide the error log.

According to the mozilla bugzilla, libxml and libxslt are not used, instead expat is the prefered xml parser.

From your bug-report, it seems that you are not using LFS. Which distribution are you using?

comment:5 by ariszlo@…, 18 years ago

I will provide the error log ASAP. I am using Yoper and I have expat-1.95.6. Isn't it possible that GLib, GTK+ or some other libraries do not work well with earlier versions of libxml/libxslt while compiling Mozilla?

comment:6 by tushar@…, 18 years ago

None of the packages that mozilla depends on depend on lib{xml,xslt} AFAIK.

comment:7 by ariszlo@…, 18 years ago

Resolution: wontfix
Status: reopenedclosed

OK. Then I am closing this bug report contrary to the fact that I could only compile Mozilla after I had updated lib{xml/xslt}.

comment:8 by tushar@…, 18 years ago

Send me the error log if possible.

comment:9 by tushar@…, 18 years ago

I just reverified the dependency tree and there is no package that depends on libxml/libxslt that mozilla is dependent on. Maybe one of the packages on your system is linked to libxml/libxslt when it should not have.

Is any of the currently installed mozilla files linked to libxml2 or libxslt? If so, please post the offending executable/library name to blfs-dev.

If you get the problem again, please post the error message to blfs-support.

Closing, Invalid.

comment:10 by bdubbs@…, 8 years ago

Milestone: old

Milestone old deleted

Note: See TracTickets for help on using tickets.