Opened 18 years ago

Closed 17 years ago

Last modified 13 years ago

#471 closed defect (fixed)

compressdoc error with relative path

Reported by: miller_lee_p@… Owned by: blfs-book@…
Priority: lowest Milestone:
Component: BOOK Version: ~CVS
Severity: trivial Keywords:
Cc:

Description

if compressdoc is invoked from /usr/bin with current directory syntax (i.e. (cd /usr/bin; ./compressdoc) the following error results

./compressdoc: line 328: ./compressdoc: No such file or directory

the script works fine if called with either absolute path or no path given and relying on $PATH to find the script.

Change History (11)

comment:1 by tushar@…, 18 years ago

Has this been fixed? There is some mention about starting with ./ in the script.

comment:2 by tushar@…, 17 years ago

Resolution: fixed
Status: newclosed

Fixed in version 20040320.0026 of compressdoc script.

comment:3 by wingman@…, 17 years ago

Resolution: fixed
Status: closedreopened
Version: 5.0CVS

got /usr/sbin/compressdoc: line 336: /usr/local/man/man1: is a directory. memory is filled up (512MB). and swap too (1GB..)... tried to laungh with relative or absolute path. same result. I'musing a CVS 30.03.2004 version.

comment:4 by tushar@…, 17 years ago

Milestone: future5.1

comment:5 by larry@…, 17 years ago

Resolution: later
Status: reopenedclosed

Needs confirming.

comment:6 by larry@…, 17 years ago

Milestone: 5.16.0

comment:7 by larry@…, 17 years ago

Resolution: later
Status: closedreopened

comment:8 by devan@…, 17 years ago

comment #3 may be unrelated I discovered a typo in the development version where the line: "$MY_NAME" ${COMP_METHOD} ${COMP_LVL} ${LN_OPT} ${VERBOSE_OPT}

${FORCE_OPT} "${DIR}/${FILE}"
exit 1

is missing a '\' at the end of the first line, should be: "$MY_NAME" ${COMP_METHOD} ${COMP_LVL} ${LN_OPT} ${VERBOSE_OPT} \

${FORCE_OPT} "${DIR}/${FILE}"
exit 1

the typo causes an "infinite" recursion loop.

comment:9 by Randy McMurchy, 17 years ago

Added a backslash to the command reported in comment #5 in R3471

comment:10 by bdubbs@…, 17 years ago

Resolution: fixed
Status: reopenedclosed

This is really two bugs. The backslash was fixed in R3471 and the script now demands an absolute path.

comment:11 by (none), 13 years ago

Milestone: 6.0

Milestone 6.0 deleted

Note: See TracTickets for help on using tickets.