Opened 20 years ago

Closed 18 years ago

Last modified 13 years ago

#5 closed defect (fixed)

openssl-0.9.7c

Reported by: markh@… Owned by: larry@…
Priority: highest Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc:

Description

Change History (31)

comment:1 by jeremy@…, 20 years ago

tar zxvf openssl-0.9.6b.tar.gz && cd openssl-0.9.6b && ./config --prefix=/usr/local shared && make && make install && ldconfig

I am aware that these instructions are not FHS-Compliant, so if someone could please post the fixes for that again, I'd greatly appreciate it!

comment:2 by markh@…, 20 years ago

Owner: changed from blfs-book@… to markh@…
Status: newassigned

comment:3 by markh@…, 20 years ago

Resolution: fixed
Status: assignedclosed

FINALLY got around to finishing this ;-)

comment:4 by markh@…, 20 years ago

Resolution: fixed
Status: closedreopened

All bugs marked as CLOSED | FIXED are being reopened for QA purposes.

comment:5 by markh@…, 20 years ago

Resolution: fixed
Status: reopenedclosed

comment:6 by jbauman@…, 20 years ago

Starting QA on this.

comment:7 by jbauman@…, 20 years ago

Keywords: VERIFIED added

Completed QA. Installed on LFS version cvs-20010907. Checked to see that man pages were accessible. Installed Links and accessed an SSL enabled web site successfully.

comment:8 by markh@…, 20 years ago

Keywords: VERIFIED removed
Resolution: fixed
Status: closedreopened
Summary: openssl-0.9.6bopenssl-0.9.6c

I'm holding off updating the book to openssl-0.9.6c until I can confirm that a report I saw somewhere on kde.org about it having a symbol clash (or something) with glibc can be refuted.

comment:9 by markh@…, 20 years ago

Milestone: 1.0

comment:10 by bdubbs@…, 20 years ago

When I make this library, I got a warning on every line (gcc 3.04).

To prevent the warnings, I edited Configure, line 301 to change -m486 to -march=i686

Consider adding this optimization/warning elimination as a note.

comment:11 by iwanek@…, 19 years ago

Summary: openssl-0.9.6copenssl-0.9.6d

comment:12 by bdubbs@…, 19 years ago

Resolution: fixed
Status: reopenedclosed

Updated version. Note that gcc 3.1 kinda breaks the config script. Well not really, but it emits two (harmless) errors. This is because gcc --version has changed format in gcc 3.x. config only calls Configure anyway so I added linux-elf to the Configure parameters and called that.

comment:13 by larry@…, 19 years ago

Resolution: fixed
Status: closedreopened
Summary: openssl-0.9.6dopenssl-0.9.6e

Version update - Security

comment:14 by larry@…, 19 years ago

Resolution: fixed
Status: reopenedclosed

comment:15 by highos@…, 19 years ago

Resolution: fixed
Status: closedreopened
Summary: openssl-0.9.6eopenssl-0.9.6g

Version increment.

comment:16 by highos@…, 19 years ago

Owner: changed from markh@… to highos@…
Status: reopenednew

Hope you don't mind if I steal this Mark, but it really should be updated.

comment:17 by highos@…, 19 years ago

Resolution: fixed
Status: newclosed

comment:18 by highos@…, 19 years ago

Resolution: fixed
Status: closedreopened
Summary: openssl-0.9.6gopenssl-0.9.6h

Version increment (0.9.6h)

comment:19 by billyoc@…, 19 years ago

Resolution: fixed
Status: reopenedclosed

comment:20 by highos@…, 19 years ago

Resolution: fixed
Status: closedreopened
Summary: openssl-0.9.6hopenssl-0.9.7

Version increment (0.9.7)

comment:21 by billyoc@…, 19 years ago

Resolution: fixed
Status: reopenedclosed

comment:22 by highos@…, 19 years ago

Resolution: fixed
Status: closedreopened
Summary: openssl-0.9.7openssl-0.9.7a

Version increment (0.9.7a)

comment:23 by larry@…, 19 years ago

Resolution: fixed
Status: reopenedclosed

comment:24 by highos@…, 18 years ago

Resolution: fixed
Status: closedreopened
Summary: openssl-0.9.7aopenssl-0.9.7b

comment:25 by larry@…, 18 years ago

Milestone: 1.0post-1.0

comment:26 by larry@…, 18 years ago

Resolution: fixed
Status: reopenedclosed

comment:27 by igor@…, 18 years ago

bug_file_loc: http://www.openssl.org/
Priority: normalhighest
Resolution: fixed
Status: closedreopened
Summary: openssl-0.9.7bopenssl-0.9.7c

Version increment (0.9.7c)

comment:28 by larry@…, 18 years ago

Owner: changed from highos@… to larry@…
Status: reopenednew

comment:29 by larry@…, 18 years ago

Status: newassigned

comment:30 by larry@…, 18 years ago

Resolution: fixed
Status: assignedclosed

comment:31 by (none), 13 years ago

Milestone: post-1.0

Milestone post-1.0 deleted

Note: See TracTickets for help on using tickets.