Opened 7 years ago

Closed 7 years ago

#6177 closed defect (wontfix)

xf86-video-cirrus fails to build

Reported by: ken@… Owned by: blfs-book@…
Priority: normal Milestone: 7.7
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Fails almost immediately:

config.status: executing libtool commands
ken@ac4tv /scratch/ken/xf86-video-cirrus-1.5.2 $make
make  all-recursive
make[1]: Entering directory '/scratch/ken/xf86-video-cirrus-1.5.2'
Making all in src
make[2]: Entering directory '/scratch/ken/xf86-video-cirrus-1.5.2/src'
  CC     alp_driver.lo
In file included from alp_driver.c:66:0:
cir.h:26:2: error: unknown type name ‘PCITAG’
  PCITAG   PciTag;
  ^
alp_driver.c: In function ‘AlpPreInit’:
alp_driver.c:799:9: warning: assignment discards ‘const’ qualifier from pointer target type
  if ((s = xf86GetOptValString(pCir->Options, OPTION_ROTATE))) {
         ^
Makefile:511: recipe for target 'alp_driver.lo' failed
make[2]: *** [alp_driver.lo] Error 1
make[2]: Leaving directory '/scratch/ken/xf86-video-cirrus-1.5.2/src'
Makefile:350: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/scratch/ken/xf86-video-cirrus-1.5.2'
Makefile:281: recipe for target 'all' failed
make: *** [all] Error 2

Google found a couple of similar logs, but no fixes. In qemu 32-bit, the modesetting driver worked with -vga cirrus. I think this driver was reinstated because it used to be the default in qemu, perhaps we should archive it again.

Change History (5)

comment:1 by bdubbs@…, 7 years ago

Try sed -i 's/PCITAG/CARD32/' src/cir.h

comment:2 by ken@…, 7 years ago

That builds and does a DESTDIR install. I assume you will understand why I'm not attempting to test it at the moment.

After my experiences in x86_64 qemu an hour or two ago, my comment about cirrus on an i686 image needs to be taken with the proverbial grain of salt.

comment:3 by Pierre Labastie, 7 years ago

Last time I built it, the cirrus driver had very low performance (10 FPS or so for glxgears), while the vesa driver (which is currently broken en server 1.17.1) gave much better performance (800 FPS on a core-i5 CPU). Now, the modesetting driver runs (with some tweaks), and give roughly the same performance as vesa (or slightly better).

comment:4 by ken@…, 7 years ago

I've now retested 64-bit in qemu, and I can confirm that the modesetting driver is working well with -vga cirrus.

comment:5 by bdubbs@…, 7 years ago

Resolution: wontfix
Status: newclosed

Arcived the cirrus driver in revision 15601.

Note: See TracTickets for help on using tickets.