Opened 18 years ago

Closed 18 years ago

Last modified 8 years ago

#662 closed defect (fixed)

lfs-bootscripts-2.0.0

Reported by: tushar@… Owned by: blfs-book@…
Priority: high Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc: DJ Lucas

Description

Change the book instructions to use the new bootscripts. Change this section to reflect lfs-bootscripts <http://www.linuxfromscratch.org/blfs/view/cvs/introduction/bootscripts.html>.

Attachments (2)

lfs-bootscripts.patch.bz2 (4.8 KB ) - added by DJ Lucas 18 years ago.
new bootscripts package described and network services addressed
lfs-bootscripts.patch.2.bz2 (4.8 KB ) - added by DJ Lucas 18 years ago.
same as the previous with the correct type

Download all attachments as: .zip

Change History (8)

comment:1 by DJ Lucas, 18 years ago

Cc: dj@… added

comment:2 by DJ Lucas, 18 years ago

* Bug 663 has been marked as a duplicate of this bug. *

comment:3 by DJ Lucas, 18 years ago

Summary: lfs-bootscriptslfs-bootscripts-2.0.0

Whoops...didn't see it last night either...but here are my comments from 663:

With the new bootscripts going into lfs-cvs, there are a few tasks to do.

Double and tripple check that new script ordering does not affect anything...if it does, fix it. Pretty sure this is already done.

Update "Using BLFS Boot Scripts" page with info on the new tarball and generic instructions to keep the source directory around as "You'll need it throughout the rest of BLFS" (pre-1 is currently in Nathan's directory and 1.99.x do not have the blfs scripts).

Update network related scripts. And I've already got this one done, patch will be attached in a few minutes...but hold the commit till at least scripts page is ready to go.

Remove all scripts from the book and use 'make install-<package> instead. Already done in the network service scripts (first patch below). Yes, No, Maybe? Needs to be discussed on BLFS-Dev.

Look at pages in the first chapters that describe scripts and get them all onto one page if appropriate

That's all I can think of for now.

by DJ Lucas, 18 years ago

Attachment: lfs-bootscripts.patch.bz2 added

new bootscripts package described and network services addressed

by DJ Lucas, 18 years ago

Attachment: lfs-bootscripts.patch.2.bz2 added

same as the previous with the correct type

comment:4 by DJ Lucas, 18 years ago

attachments.isobsolete: 01

comment:5 by tushar@…, 18 years ago

Resolution: fixed
Status: newclosed

courier init script is not yet available. the rest of the packages now use LFS style bootscripts.

comment:6 by bdubbs@…, 8 years ago

Milestone: old

Milestone old deleted

Note: See TracTickets for help on using tickets.