Opened 17 years ago

Closed 17 years ago

Last modified 7 years ago

#764 closed defect (duplicate)

gnome-print -0.37 freetype-2.1.7 compilation fail

Reported by: danielearosio@… Owned by: blfs-book@…
Priority: high Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc:

Description

It seems a problem related to the upgrade to freetype-2.1.7.

In file included from ../libgnomeprint/gnome-font-private.h:25,

from gnome-print-ps2.c:51:

/usr/include/freetype2/freetype/freetype.h:20:2: #error "`ft2build.h' hasn't be en included yet!" /usr/include/freetype2/freetype/freetype.h:21:2: #error "Please always use macr os to include FreeType header files." /usr/include/freetype2/freetype/freetype.h:22:2: #error "Example:" /usr/include/freetype2/freetype/freetype.h:23:2: #error " #include <ft2build.h

"

/usr/include/freetype2/freetype/freetype.h:24:2: #error " #include FT_FREETYPE _H" make[2]: * [gnome-print-ps2.lo] Error 1 make[2]: Leaving directory `/usr/src/gnome-print-0.37/libgnomeprint' make[1]: * [all-recursive] Error 1 make[1]: Leaving directory `/usr/src/gnome-print-0.37' make: * [all-recursive-am] Error 2

Change History (2)

comment:1 by igor@…, 17 years ago

Resolution: duplicate
Status: newclosed

Missed this one when I was reporting the same bug.

* This bug has been marked as a duplicate of 765 *

comment:2 by bdubbs@…, 7 years ago

Milestone: old

Milestone old deleted

Note: See TracTickets for help on using tickets.