Opened 17 years ago

Closed 17 years ago

Last modified 13 years ago

#765 closed defect (fixed)

gnome-print doesn't compile with freetype-2.1.7

Reported by: igor@… Owned by: blfs-book@…
Priority: high Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc: danielearosio@…

Description

See URL.

Attachments (1)

gnome-print-0.37-ft217-fixes.patch (2.3 KB ) - added by jeremy@… 17 years ago.
Fix for compile issue with FT 2.1.7

Download all attachments as: .zip

Change History (8)

comment:1 by igor@…, 17 years ago

Milestone: future5.1

comment:2 by bdubbs@…, 17 years ago

Looking at freetype.h, we have:

#ifndef FT_FREETYPE_H #error "`ft2build.h' hasn't been included yet!" #error "Please always use macros to include FreeType header files." #error "Example:" #error " #include <ft2build.h>" #error " #include FT_FREETYPE_H" #endif

If we just removed this or commented it out and added #include <ft2build.h>

when freetype is installed, it would fix the problem for all the packages that use it. Any objections?

comment:3 by igor@…, 17 years ago

Cc: danielearosio@… added

comment:4 by igor@…, 17 years ago

* Bug 764 has been marked as a duplicate of this bug. *

comment:5 by tushar@…, 17 years ago

The freetype developers deliberately added that to force dependent packages to rectify how they include freetype headers. I don't think we should reverse that.

by jeremy@…, 17 years ago

Fix for compile issue with FT 2.1.7

comment:6 by igor@…, 17 years ago

Resolution: fixed
Status: newclosed

comment:7 by (none), 13 years ago

Milestone: 5.1

Milestone 5.1 deleted

Note: See TracTickets for help on using tickets.