Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#8979 closed enhancement (fixed)

firefox-52.0

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 8.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Security fixes at https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox/#firefox52, it also drops support for NPAPI plugins other than flash.

And there I was hoping flash would finally die.

What the release notes don't say is that they've made pulse a hard requirement for audio - I've got pics for youtube nad local mp4, ogv files - but no sound. Looks like https://bugzilla.mozilla.org/show_bug.cgi?id=1247056 : in theory, pulse is dlopened so it might be possible to add it after firefox. But we disable pulse in our mozconfig, and that was not flagged up as an invalid option.

I'll upload the latest version of the patch for system graphite2 and harfbuzz.

Change History (6)

comment:1 by ken@…, 5 years ago

Status: newassigned

comment:2 by ken@…, 5 years ago

Rebuilt it on top of pulse. I can see the following in log:

checking for libpulse... yes
checking MOZ_PULSEAUDIO_CFLAGS... -D_REENTRANT
checking MOZ_PULSEAUDIO_LIBS... -lpulse

But still no sound on youtube or local mp4 files. I'll have to look at configuring pulse when I've had some sleep.

comment:3 by ken@…, 5 years ago

Minor note after building it (using alsa) on a different machine: I had to remove flashblock to get video output on any of hte videos I tried! Sound was fine, so noting this in case anybody else hits that problem.

comment:4 by ken@…, 5 years ago

Resolution: fixed
Status: assignedclosed

comment:5 by bdubbs@…, 5 years ago

Milestone: 8.1m8.1

Milestone renamed

comment:6 by bdubbs@…, 5 years ago

Milestone: m8.18.1

Milestone renamed

Note: See TracTickets for help on using tickets.