Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#8980 closed defect (fixed)

pulseaudio not correctly linked.

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 8.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Trying 'pulseaudio -c' on the off-chance that getting it to work might be quick:

ken@plexi ~ $pulseaudio -c
pulseaudio: Relink `/usr/lib/libICE.so.6' with /lib/libpthread.so.0' for IFUNC symbol `longjmp'
pulseaudio: invalid option -- 'c'
E: [pulseaudio] main.c: Failed to parse command line.

Change History (17)

comment:1 by bdubbs@…, 5 years ago

I rebuilt libICE with:

./configure $XORG_CONFIG ICE_LIBS=-lpthread

and the Relink message went away.

The -c shoule be -C I think.

I still had an error though:

E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files

We do not use --disable-bluez5. Rebuilding with that gets rid of all warnings/errrors.

I'm not sure what pulseaudio -C does however. It just seems to hang.

in reply to:  1 comment:2 by Pierre Labastie, 5 years ago

Replying to bdubbs@…:

I rebuilt libICE with:

./configure $XORG_CONFIG ICE_LIBS=-lpthread

and the Relink message went away.

The -c shoule be -C I think.

I still had an error though:

E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files

Have you run the command:

rm /etc/dbus-1/system.d/pulseaudio-system.conf

We do not use --disable-bluez5. Rebuilding with that gets rid of all warnings/errrors.

I'm not sure what pulseaudio -C does however. It just seems to hang.

I've built pulseaudio several times as per the book instructions, and it seems to work out of the box. It is even able to find the correct sound device, while I need to pass some switch to the kernel (or to the snd-hda-intel module) to be able to use alsa-{lib,utils}.

comment:3 by ken@…, 5 years ago

On my machine, I've renamed it to /etc/dbus-1/system.d/pulseaudio-system.conf.hidden (deleting can be expensive)

I've just had sound working by manually enabling alsa and disabling pulse in firefox, will need to rebuild firefox again to debug pulse.

in reply to:  1 comment:4 by ken@…, 5 years ago

Replying to bdubbs@…:

The -c shoule be -C I think.

Yes, that gives me

N: [pulseaudio] alsa-util.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
N: [pulseaudio] alsa-util.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
E: [pulseaudio] module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
E: [pulseaudio] module.c: Failed to load module "module-console-kit" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

I was fooled because the command renders very small in my choice of fonts, and the capital -C is smaller than the following a of 'and then'

comment:5 by bdubbs@…, 5 years ago

I do not have /etc/dbus-1/system.d/pulseaudio-system.conf. I do not recall creating or deleting that file.

I was testing on my -dev system (via ssh) and although the dbus daemon was running, a window manager was not. I can run speaker-test or play an mp4 file and audio works.

I'm not sure if my configuration is complete or not.

comment:6 by bdubbs@…, 5 years ago

Owner: changed from blfs-book@… to ken@…

comment:7 by ken@…, 5 years ago

Status: newassigned

comment:8 by ken@…, 5 years ago

The libICE change definitely helps. After metaphorically running around the block a few times, I looked at syslog and realised I didn't use the sed to suppress loading the console-kit module: whenever I've installed pulse in the past it has come after console-kit, I need to extend the tests in my script.

comment:9 by ken@…, 5 years ago

That fixed it for me, so apart from libICE it was user error.

On this machine I have found sound to often be very quiet, but now with pulse both the volume seems perfectly adequate. I think I can decide to like pulse.

Bruce: re bluez5 - do you have any of that installed ? My original log shows that both BlueZ 4 and BlueZ 5 are not enabled.

I'll add the switch, and fix libICE.

comment:10 by bdubbs@…, 5 years ago

Yes, I have BT5 installed, but I disabled it for PA.

in reply to:  10 ; comment:11 by ken@…, 5 years ago

Replying to bdubbs@…:

Yes, I have BT5 installed, but I disabled it for PA.

Thanks for the reply, but I don't understand what you did to disable it for pulse.

On the build where you reported

E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files 

had pulse been built against BlueZ5 ?

In the configure script, BLUEZ 5 support depends on sbc and D-Bus. It defaults to enabled if D-Bus and sbc are installed AND BLUEZ 5 has NOT been disabled.

Ah : perhaps you had D-Bus and SBC installed, and did not explicitly use --disable-bluez5 ?

in reply to:  11 ; comment:12 by bdubbs@…, 5 years ago

Replying to ken@…:

Replying to bdubbs@…:

Yes, I have BT5 installed, but I disabled it for PA.

Thanks for the reply, but I don't understand what you did to disable it for pulse.

--disable-bluez5

On the build where you reported

E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files 

had pulse been built against BlueZ5 ?

That was before I disabled BT.

In the configure script, BLUEZ 5 support depends on sbc and D-Bus. It defaults to enabled if D-Bus and sbc are installed AND BLUEZ 5 has NOT been disabled.

Ah : perhaps you had D-Bus and SBC installed, and did not explicitly use --disable-bluez5 ?

Two instances. The first with BT5. The second without.

in reply to:  12 comment:13 by ken@…, 5 years ago

Replying to bdubbs@…:

Replying to ken@…:

Replying to bdubbs@…:

Yes, I have BT5 installed, but I disabled it for PA.

Thanks for the reply, but I don't understand what you did to disable it for pulse.

--disable-bluez5

I think we are at cross-purposes. On that earlier build where you got the error at runtime, did you have bluez when you compiled pulse, and if so, had you done anything to remove bluez between the compile and runtime ?

I understand that you have now had to rebuild pulse with bluez disabled, but I'm still trying to understand *why*. I suggested that if SBC and D-Bus are present, then bluez5 might be enabled by default, but I'm not yet convinced that actually happens.

comment:14 by ken@…, 5 years ago

Forget the question, please - I've now confirmed that if D-Bus and SBC are both installed, bluez5 *is* enabled by default without any test to see if it is present.

Also, bluez appears to now be a compile-time dependency.

comment:15 by ken@…, 5 years ago

Resolution: fixed
Status: assignedclosed

Actioned at r18464.

comment:16 by bdubbs@…, 5 years ago

Milestone: 8.1m8.1

Milestone renamed

comment:17 by bdubbs@…, 5 years ago

Milestone: m8.18.1

Milestone renamed

Note: See TracTickets for help on using tickets.