Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3982 closed task (fixed)

readline-7.0

Reported by: bdubbs@… Owned by: lfs-book@…
Priority: normal Milestone: 8.0
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

New major version.

  1. Changes to Readline
  1. A bug that caused vi-mode .' to be unable to redo c', d', and y' commands with modifiers was fixed.
  1. Fixed a bug that caused callback mode to dump core when reading a multiple-key sequence (e.g., arrow keys).
  1. Fixed a bug that caused the redisplay code to erase some of the line when using horizontal scrolling with incremental search.
  1. Readline's input handler now performs signal processing if read(2) is interrupted by SIGALRM or SIGVTALRM.
  1. Fixed a problem with revert-all-at-newline freeing freed memory.
  1. Clarified the documentation for the history_quotes_inhibit_expansion variable to note that it inhibits scanning for the history comment character and that it only affects double-quoted strings.
  1. Fixed an off-by-one error in the prompt printed when performing searches.
  1. Use pselect(2), if available, to wait for input before calling read(2), so a SIGWINCH can interrupt it, since it doesn't interrupt read(2).
  1. Some memory leaks caused by signals interrupting filename completion have been fixed.
  1. Reading EOF twice on a non-empty line causes EOF to be returned, rather than the partial line. This can cause partial lines to be executed on SIGHUP, for example.
  1. Fixed a bug concerning deleting multibyte characters from the search string while performing an incremental search.
  1. Fixed a bug with tilde expanding directory names in filename completion.
  1. Fixed a bug that did not allow binding sequences beginning with a `\'.
  1. Fixed a redisplay bug involving incorrect line wrapping when the prompt contains a multibyte character in the last screen column.
  1. Fixed a bug that caused history expansion to disregard characters that are documented to delimit a history event specifier without requiring `:'.
  1. Fixed a bug that could cause reading past the end of a string when reading the value when binding the set of isearch terminators.
  1. Fixed a bug that caused readline commands that depend on knowing which key invoked them to misbehave when dispatching key sequences that are prefixes of other key bindings.
  1. Paren matching now works in vi insert mode.
  1. Colored completion prefixes are now displayed using a different color, less likely to collide with files.
  1. Fixed a bug that caused vi-mode character search to misbehave when running in callback mode.
  1. Fixed a bug that caused output to be delayed when input is coming from a macro in vi-mode.
  1. Fixed a bug that caused the vi-mode `.' command to misbehave when redoing a multi-key key sequence via a macro.
  1. Fixed a bug that caused problems with applications that supply their own input function when performing completion.
  1. When read returns -1/EIO when attempting to read a key, return an error instead of line termination back to the caller.
  1. Updated tty auditing feature based on patch from Red Hat.
  1. Fixed a bug that could cause the history library to crash on overflows introduced by malicious editing of timestamps in the history file.

aa. The history file writing functions only attempt to create and use a backup history file if the history file exists and is a regular file.

bb. Fixed an out-of-bounds read in readline's internal tilde expansion interface.

cc. Fixed several redisplay bugs with prompt strings containing multibyte and non-visible characters whose physical length is longer than the screen width.

dd. Fixed a redisplay bug with prompt strings containing invisible characters whose physical length exceeds the screen width and using incremental search.

ee. Readline prints more descriptive error messages when it encounters errors while reading an inputrc file.

ff. Fixed a bug in the character insertion code that attempts to optimize typeahead when it reads a character that is not bound to self-insert and resets the key sequence state.

gg. When refreshing the line as the result of a key sequence, Readline attempts to redraw only the last line of a multiline prompt.

hh. Fixed an issue that caused completion of git commands to display incorrectly when using colored-completion-prefix.

  1. Fixed several redisplay bugs having to do with multibyte characters and invisible characters in prompt strings.

jj. Fixed a bug that caused mode strings to be displayed incorrectly if the prompt was shorter than the mode string.

  1. New Features in Readline
  1. The history truncation code now uses the same error recovery mechansim as the history writing code, and restores the old version of the history file on error. The error recovery mechanism handles symlinked history files.
  1. There is a new bindable variable, `enable-bracketed-paste', which enables support for a terminal's bracketed paste mode.
  1. The editing mode indicators can now be strings and are user-settable (new emacs-mode-string', vi-cmd-mode-string' and `vi-ins-mode-string' variables). Mode strings can contain invisible character sequences. Setting mode strings to null strings restores the defaults.
  1. Prompt expansion adds the mode string to the last line of a multi-line prompt (one with embedded newlines).
  1. There is a new bindable variable, `colored-completion-prefix', which, if set, causes the common prefix of a set of possible completions to be displayed in color.
  1. There is a new bindable command `vi-yank-pop', a vi-mode version of emacs-mode yank-pop.
  1. The redisplay code underwent several efficiency improvements for multibyte locales.
  1. The insert-char function attempts to batch-insert all pending typeahead that maps to self-insert, as long as it is coming from the terminal.
  1. rl_callback_sigcleanup: a new application function that can clean up and unset any state set by readline's callback mode. Intended to be used after a signal.
  1. If an incremental search string has its last character removed with DEL, the resulting empty search string no longer matches the previous line.
  1. If readline reads a history file that begins with `#' (or the value of the history comment character) and has enabled history timestamps, the history entries are assumed to be delimited by timestamps. This allows multi-line history entries.
  1. Readline now throws an error if it parses a key binding without a terminating `:' or whitespace.
  1. The default binding for W in vi mode now uses word boundaries specified by Posix (vi-unix-word-rubout is bindable command name).
  1. rl_tty_set_echoing: application-callable function that controls whether or not readline thinks it is echoing terminal output.
  1. Handle >| and strings of digits preceding and following redirection specifications as single tokens when tokenizing the line for history expansion.
  1. Fixed a bug with displaying completions when the prefix display length is greater than the length of the completions to be displayed.
  1. The :p history modifier now applies to the entire line, so any expansion specifying :p causes the line to be printed instead of expanded.
  1. New application-callable function: rl_pending_signal(): returns the signal number of any signal readline has caught but not yet handled.
  1. New application-settable variable: rl_persistent_signal_handlers: if set to a non-zero value, readline will enable the readline-6.2 signal handler behavior in callback mode: handlers are installed when rl_callback_handler_install is called and removed removed when a complete line has been read.

Change History (2)

comment:1 by bdubbs@…, 5 years ago

Resolution: fixed
Status: newclosed

Fixed at revision 11128.

comment:2 by bdubbs@…, 5 years ago

Milestone: 7.118.0

Milestone renamed

Note: See TracTickets for help on using tickets.