Opened 4 months ago

Closed 4 months ago

#4898 closed enhancement (fixed)

diffutils-3.8

Reported by: Douglas R. Reno Owned by: lfs-book
Priority: normal Milestone: 11.0
Component: Book Version: git
Severity: normal Keywords:
Cc:

Description

New minor version

Change History (2)

comment:1 by Bruce Dubbs, 4 months ago

Noteworthy changes in release 3.8 (2021-08-01) [stable]

  • Incompatible changes

diff no longer treats a closed stdin as representing an absent file in usage like 'diff --new-file - foo <&-'. This feature was rarely if ever used and was not portable to POSIX platforms that reopen stdin on exec, such as SELinux if the process underwent an AT_SECURE transition, or HP-UX even if not setuid.

  • Bug fixes

diff and related programs no longer get confused if stdin, stdout, or stderr are closed. Previously, they sometimes opened files into file descriptors 0, 1, or 2 and then mistakenly did I/O with them that was intended for stdin, stdout, or stderr.

cmp, diff and sdiff no longer treat negative command-line option-arguments as if they were large positive numbers.

comment:2 by Bruce Dubbs, 4 months ago

Resolution: fixed
Status: newclosed

Fixed at commit 9c7598cc15b7ec877b0350fbdc9d1d1fe466405b

Package updates.
    Update to glibc-2.34.
    Update to diffutils-3.8.
    Update to libcap-2.52.
Note: See TracTickets for help on using tickets.