Opened 4 months ago

Closed 4 months ago

#4901 closed enhancement (fixed)

grep-3.7

Reported by: Xi Ruoyao Owned by: Bruce Dubbs
Priority: normal Milestone: 11.0
Component: Book Version: git
Severity: normal Keywords:
Cc:

Description

A test of grep-3.6 is failing in LFS. The reason is gnulib shipped in the tarball wasn't adapted for glibc-2.34 SIGSTKSZ change. Now the upstream has updated the shipped gnulib and plans to make a release soon:

https://git.savannah.gnu.org/cgit/grep.git/commit/?id=743be2c498b768db1dea3fc624c17d789b9ba308 https://lists.gnu.org/archive/html/grep-devel/2021-08/msg00000.html

We'd better make it into lfs 11.0.

Change History (3)

comment:1 by Bruce Dubbs, 4 months ago

In addition to the NEWS-noted items, there have been improvements in both regex and dfa gnulib modules, so I want to make a release in the next week or so.

https://meyering.net/grep/grep-3.6.27-20b4.tar.xz

NEWS

  • Changes in behavior
  • Use of the --unix-byte-offsets (-u) option now evokes a warning. Since 3.1, this Windows-only option has had no effect.
  • Bug fixes
  • Preprocessing N patterns would take at least O(N2) time when too many patterns hashed to too few buckets. This now takes seconds, not days: : | grep -Ff <(seq 6400000 | tr 0-9 A-J)
Changes in gnulib since v3.6:

* gnulib bd90572c03...1cb09be022 (855): (showing only regex- and dfa-related changes)
  > regex-quote: Improve GCC 11 allocation-deallocation checking.
  > dfa: Improve GCC 11 allocation-deallocation checking.
  > dfa: omit unneeded malloc+free
  > dfa: improve -fanalyzer malloc checking
  > regex: pacify GCC 11.2.1's -fanalyzer
  > regex: pacify GCC 11.2 -fanalyzer
  > regex: modernize to newer regex bugset
  > regex: fix shell quoting problem in configuration
  > regex: fix undefined behavior
  > dfa: prefer idx_t for indexes
  > regex-tests: test for regressions fixed by the previous commit
  > regex: fix match with possessive quantifier
  > regex-tests: remove incorrect comment
  > dfa, etc.: prefer xreallocarray to older name
  > xalloc: new function xpalloc, from dfa
  > regex: Allow locking optimization independently of 'unlocked-io'.
  > regex: fix comment location
  > regex-tests: add bug 11053 test
  > regex: debug check for set member duplicates
  > regex: fix longstanding backref match bug
  > regex: avoid duplicate in espilon closure
  > regex-tests: fix typo
  > regex: make it easier to merge into glibc
  > regex: minor refactoring
  > regex: avoid undefined behavior
  > regex: improve comments
  > fnmatch, regex, fts: FALLTHROUGH consistency
  > regex: stop using alloca
  > regexec: remove alloca usage in build_trtable
  > regex: remove alloca usage on regex set_regs
  > regex-tests: tweak to avoid a clang-10 warning
  > regex: remove glibc21.m4

comment:2 by Bruce Dubbs, 4 months ago

Owner: changed from lfs-book to Bruce Dubbs
Status: newassigned
Summary: grep-3.7 (wait for it before package freeze)grep-3.7

The package is available now.

comment:3 by Bruce Dubbs, 4 months ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.