Opened 3 months ago

Closed 3 months ago

#5029 closed enhancement (fixed)

libtool-2.4.7

Reported by: Bruce Dubbs Owned by: Xi Ruoyao
Priority: normal Milestone: 11.2
Component: Book Version: git
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by Xi Ruoyao, 3 months ago

Owner: changed from lfs-book to Xi Ruoyao
Status: newassigned

comment:2 by Xi Ruoyao, 3 months ago

I don't see anything may benefit LFS:

Noteworthy changes in release 2.4.7 (2022-03-16) [stable]

New features:

  • Libtool script now supports (configure-time and runtime) ARFLAGS variable, which obsoletes AR_FLAGS. This is due to naming conventions among other *FLAGS and to be consistent with Automake's ARFLAGS.
  • Gnulib testsuite is enabled and run during 'make check'.
  • Support the Windows version of the Intel C Compiler (icl) in libtool script.
  • Pass '-fsanitize=*' flags for GCC and LLVM, and '-specs=*' for GCC to linker.
  • Pass '-Xassembler=*' and '-Wa,*' flag to compilers and linkers.
  • The variable 'FILECMD' with default value of '/usr/bin/file' was used to replace existing hard coded references to '/usr/bin/file'.
  • Add MidnightBSD support.

Important incompatible changes:

  • Libtool changed ARFLAGS/AR_FLAGS default from 'cru' to 'cr'.
  • Do not pass '-pthread' to Solaris linker.
  • 'libtool' and 'libtoolize' scripts now use '#! /usr/bin/env sh' shebang. Previously '#! /bin/sh' was used, which presents challenges for containerized environments.

Bug fixes:

  • Fix significant slowdown of libtoolize for certain projects (regression introduced in 2.4.3 release) caused by infinite m4 macro recursion.
  • Mitigate the slowdown of libtool script (introduced in v2.4.3) caused by increased number of calls to '$SED $sed_quote_subst' (bug#20006).
  • Properly parse and export TLS symbols on AIX.
  • Various bug fixes surrounding use of 'sed'.
  • Darwin systems set proper "allow undefined" flag on OSX 11, and PowerPC 10.5.
  • Removed some deprecated tests related to 'Makefile.inc' files.

comment:3 by Xi Ruoyao, 3 months ago

Resolution: fixed
Status: assignedclosed

Fixed at 0a28db3.

Note: See TracTickets for help on using tickets.