Opened 3 months ago

Closed 3 months ago

#5032 closed enhancement (fixed)

man-db-2.10.2

Reported by: Bruce Dubbs Owned by: Xi Ruoyao
Priority: normal Milestone: 11.2
Component: Book Version: git
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by Xi Ruoyao, 3 months ago

man-db 2.10.2 (17 March 2022)

Build:

  • Regenerating man-db's build system now explicitly requires Automake >= 1.14. (This was already the case since at least man-db 2.10.0, but was previously undocumented.)

Fixes:

  • Make man -H sleep for a few seconds after starting the browser, since it may background itself before loading files (Dr. Werner Fink).
  • If an override directory is configured using --with-override-dir, it is now applied more consistently when building the manpath, and whether a page was found in an override directory is considered when sorting candidates for display (Mihail Konev).

Improvements:

  • Make the man-db manual build reproducible.
  • Add some hardening options to the systemd service.
  • configure now has a --with-snapdir option, for use on systems where snapd is configured to use a directory other than /snap.

comment:2 by Xi Ruoyao, 3 months ago

Owner: changed from lfs-book to Xi Ruoyao
Status: newassigned

comment:3 by Xi Ruoyao, 3 months ago

Resolution: fixed
Status: assignedclosed

Fixed at 0a28db3.

Note: See TracTickets for help on using tickets.