Opened 3 months ago

Closed 3 months ago

#5037 closed enhancement (fixed)

Python-3.10.4

Reported by: Bruce Dubbs Owned by: lfs-book
Priority: normal Milestone: 11.2
Component: Book Version: git
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by ken@…, 3 months ago

https://www.python.org/downloads/release/python-3104/

This is a special release that fixes a regression introduced by https://bugs.python.org/issue46968 which caused Python to no longer build on Red Hat Enterprise Linux 6. There are only 10 other bugfixes on top of 3.10.3 in this release.

comment:2 by pierre, 3 months ago

Reported on the mailing list: the configure switch should be --ensurepip=upgrade instead of --ensurepip=yes. But since upgrade is the default, and yes is still accepted and equivalent to upgrade: better remove the option altogether.

comment:3 by Bruce Dubbs, 3 months ago

Resolution: fixed
Status: newclosed

Fixed at commit 676f0fdcecb3d53217a274db1138ff22005bea9a

Package updates.
    Update to sysvinit-3.02.
    Update to zlib-1.2.12.
    Update to expat-2.4.8.
    Update to Jinja2-3.1.1.
    Update to Python-3.10.4.
    Update to procps-ng-4.0.0.
    Update to iproute2-5.17.0.
    Update to meson-0.62.0.
    Update to linux-5.17.1.
    Update to util-linux-2.38.
Note: See TracTickets for help on using tickets.