Opened 6 months ago

Closed 6 months ago

#14547 closed enhancement (fixed)

dvisvgm-2.11.1

Reported by: Douglas R. Reno Owned by: ken@…
Priority: normal Milestone: 10.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

Change History (8)

comment:1 by ken@…, 6 months ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:2 by ken@…, 6 months ago

This is a small maintenance release.

Fixed possible ambiguities of GID to charcode mappings (issue #147).

Refactored the representation of token objects in class Calculator.

Few minor code and test improvements.

comment:3 by ken@…, 6 months ago

FTBFS with autoconf-2.70.

Making all in tests
 cd .. && /bin/sh /scratch/working/dvisvgm-2.11.1/missing automake-1.16 --foreign tests/Makefile
aclocal.m4:17: warning: this file was generated for autoconf 2.69.
You have another version of autoconf.  It may work, but is not guaranteed to.
If you have problems, you may need to regenerate the build system entirely.
To do so, use the procedure documented by the package, typically 'autoreconf'.
configure.ac:14: error: version mismatch.  This is Automake 1.16.3,
configure.ac:14: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:14: comes from Automake 1.16.2.  You should recreate
configure.ac:14: aclocal.m4 with aclocal and run automake again.

Fixed by running autoreconf -fiv.

Last edited 6 months ago by ken@… (previous) (diff)

comment:4 by Douglas R. Reno, 6 months ago

I think autoreconf -iv might fix this one. It looks like the root cause might be because aclocal.m4 in the source tree comes from automake-1.16.2, but we're using automake-1.16.3.

comment:5 by ken@…, 6 months ago

Resolution: fixed
Status: assignedclosed

in reply to:  4 comment:6 by ken@…, 6 months ago

Replying to renodr:

I think autoreconf -iv might fix this one. It looks like the root cause might be because aclocal.m4 in the source tree comes from automake-1.16.2, but we're using automake-1.16.3.

Sorry, missed that comment. But I actually tried that as the first stage - it made a difference, but not a good one: got as far as 'Making all in tests', did nothing, no error messages and my client script exited although it still managed to return a status of 0 (my script to build dvisvgm and its deps reports the status after dvisvgm, ISTR I've had a similar odd exit in a previous version).

comment:7 by ken@…, 6 months ago

Resolution: fixed
Status: closedreopened

Doug said that the tests needing 'python' failed for him, although on my builds yesterday that passed (and I too lack /usr/bin/python). But retrying today thy fail for me too:

make[3]: Entering directory '/tmp/dvisvgm-2.11.1/tests'
python genhashcheck.py ../src/AGLTable.hpp ../libs/xxHash/xxhash.h >hashcheck.cpp
/bin/sh: line 1: python: command not found
make[3]: *** [Makefile:3513: hashcheck.cpp] Error 127
make[3]: Leaving directory '/tmp/dvisvgm-2.11.1/tests'
make[2]: *** [Makefile:3256: check-am] Error 2
make[2]: Leaving directory '/tmp/dvisvgm-2.11.1/tests'
make[1]: *** [Makefile:2522: check-recursive] Error 1
make[1]: Leaving directory '/tmp/dvisvgm-2.11.1/tests'
make: *** [Makefile:448: check-recursive] Error 1

As Doug pointed out, this is because the autoreconf regenerates the Makefile.in. Reopening.

comment:8 by ken@…, 6 months ago

Resolution: fixed
Status: reopenedclosed

Further fix in r24157

Note: See TracTickets for help on using tickets.