Opened 15 years ago

Closed 15 years ago

#2097 closed task (fixed)

HAL-0.5.7.1

Reported by: dnicholson@… Owned by: dnicholson@…
Priority: high Milestone: 6.2.0
Component: BOOK Version: SVN
Severity: normal Keywords: HAL
Cc:

Description

Version upgrade. This one is important to get in before 6.2 because it deals with HAL breaking with new sysfs in linux-2.6.17.

http://lists.freedesktop.org/archives/hal/2006-July/005689.html

Change History (8)

comment:1 by Randy McMurchy, 15 years ago

I'm not sure why it is important to be compatible with linux-2.6.17 when our target is linux-2.6.16. Unless I'm missing something (I'll wait a day or so for discusstion), this bug will be dropped down to 'normal' priority.

comment:2 by dnicholson@…, 15 years ago

Owner: changed from blfs-book@… to dnicholson@…
Status: newassigned

I guess I wasn't explicit enough there. If there's a known issue going forward (with a fix in a stable package), it would be a big disservice for us to ignore it. People are going to install linux-2.6.17 despite our target version being 2.6.16. Technically, you're right, though.

comment:3 by dnicholson@…, 15 years ago

Owner: changed from dnicholson@… to Randy McMurchy
Status: assignednew

comment:4 by Randy McMurchy, 15 years ago

Summary: HAL-0.5.7.1HAL-0.5.8

comment:5 by Randy McMurchy, 15 years ago

Owner: changed from Randy McMurchy to blfs-book@…

Unassigning myself from the bug as I feel too far removed from current HAL/D-BUS (knowledge-wise) to confidently do the update.

comment:6 by Randy McMurchy, 15 years ago

Summary: HAL-0.5.8HAL-0.5.7.1

It has been determined that for BLFS-6.2.0, we should update HAL to 0.5.7.1. After that, we can simply open up a new ticket for the 0.5.8 update. The comments in this ticket will no longer be valid.

comment:7 by dnicholson@…, 15 years ago

Owner: changed from blfs-book@… to dnicholson@…
Status: newassigned

I forgot about the ticket. For the record...

HAL-0.5.8 has a lot of changes that have not been tested in the context of BLFS-6.2.0. HAL-0.5.7.1 provides a working system that has been tested in conjunction with KDE-3.5.x and GNOME-2.14.x, the main users of HAL in the BLFS book.

comment:8 by dnicholson@…, 15 years ago

Resolution: fixed
Status: assignedclosed

Fixed in r6412.

Note: See TracTickets for help on using tickets.